✔️ 문제 설명
문제
홀수인 자연수 N이 주어지면, 다음과 같이 1부터 N2까지의 자연수를 달팽이 모양으로 N×N의 표에 채울 수 있다.
9 | 2 | 3 |
8 | 1 | 4 |
7 | 6 | 5 |
25 | 10 | 11 | 12 | 13 |
24 | 9 | 2 | 3 | 14 |
23 | 8 | 1 | 4 | 15 |
22 | 7 | 6 | 5 | 16 |
21 | 20 | 19 | 18 | 17 |
N이 주어졌을 때, 이러한 표를 출력하는 프로그램을 작성하시오. 또한 N2 이하의 자연수가 하나 주어졌을 때, 그 좌표도 함께 출력하시오. 예를 들어 N=5인 경우 6의 좌표는 (4,3)이다.
입력
첫째 줄에 홀수인 자연수 N(3 ≤ N ≤ 999)이 주어진다. 둘째 줄에는 위치를 찾고자 하는 N2 이하의 자연수가 하나 주어진다.
출력
N개의 줄에 걸쳐 표를 출력한다. 각 줄에 N개의 자연수를 한 칸씩 띄어서 출력하면 되며, 자릿수를 맞출 필요가 없다. N+1번째 줄에는 입력받은 자연수의 좌표를 나타내는 두 정수를 한 칸 띄어서 출력한다.
예제 입력 1 복사
7
35
예제 출력 1 복사
49 26 27 28 29 30 31
48 25 10 11 12 13 32
47 24 9 2 3 14 33
46 23 8 1 4 15 34
45 22 7 6 5 16 35
44 21 20 19 18 17 36
43 42 41 40 39 38 37
5 7
✔️ 문제 풀이
손으로 그려보면서 규칙을 찾아보니 ⬆️상 ➡️우 ⬇️하 ⬅️좌 순서로 달팽이가 가는 패턴이 반복되었고,
1 1 2 2 3 3 4 4 5 5 6 6 ... 이런식으로 달팽이가 가는 칸 수가 등차수열 비스무리하게 올라간다는 것을 확인하였다.
이 점을 염두에 두고 구현을 해보았다.. 약간 복잡하지만
import java.awt.*;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.BufferedReader;
import java.util.*;
class Main{
static int n, findNum;
static int[][] arr;
static int[] di = {-1, 0, 1, 0}; //상우하좌
static int[] dj = {0, 1, 0, -1};
static StringBuilder sb = new StringBuilder();
public static void main(String[] args)throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
n = Integer.parseInt(br.readLine());
findNum = Integer.parseInt(br.readLine());
arr = new int[n+1][n+1];
snail();
StringBuilder print = new StringBuilder();
for(int i = 1; i< n+1; i++){
for(int j = 1; j < n+1; j++ ){
print.append(arr[i][j]+ " ");
}
print.append('\n');
}
System.out.print(print);
System.out.println(sb);
}
public static void snail(){
int move = 1;
int current_i = n/2 + 1;
int current_j = n/2 + 1;
int num = 1;
if(findNum == 1){
sb.append(current_i + " " +current_j);
}
arr[current_i][current_j] = num ++;
int cnt = 0;
int direction_cnt = 0;
while(true){
if(cnt == 2) {
move++;
cnt = 0;
}
for(int i = 0; i < move; i++){
current_i += di[direction_cnt];
current_j += dj[direction_cnt];
if(num == findNum) {
sb.append(current_i + " " +current_j);
}
arr[current_i][current_j] = num ++;
if(num == (n*n +1)) return;
}
direction_cnt ++;
if(direction_cnt == 4) direction_cnt = 0;
cnt++;
}
}
}
✔️ 발생 오류들
[2% 에서 메모리 초과]
System.out 표준 출력을 이용해서 배열을 출력했을 때 메모리 초과가 났다..
→해결
StringBuilder print = new StringBuilder();
for(int i = 1; i< n+1; i++){
for(int j = 1; j < n+1; j++ ){
print.append(arr[i][j]+ " ");
}
print.append('\n');
}
이렇게 배열 출력을 StringBuilder를 이용하니 해결됨 !!
[60% 쯤 에서 틀림]
만약 위치를 찾고자 하는 수가 1 이라면 n/2+1 , n/2+1 을 출력해주어야한다.
하지만, 나같은 경우는 배열에 1을 넣긴 했지만 검사는 2부터 시작하므로 1의 위치를 제대로 출력하지 못 했다.
→해결
if(findNum == 1){
sb.append(current_i + " " +current_j);
}
1일 때 따로 처리를 해주어 문제를 해결하였다.
'Coding Test > 백준 알고리즘 풀이' 카테고리의 다른 글
[백준] 4963 섬의 개수 : 실버 2(java) - BFS (0) | 2025.03.09 |
---|---|
[백준] 2583 영역구하기 : 실버 1 (java) - DFS (0) | 2024.12.01 |
[백준] 10026 적록 색약 : 골드 5 (java) - bfs & dfs (0) | 2024.11.28 |
[백준] 20006 랭킹전 대기열 : 실버 2 (java) - 구현 (0) | 2024.11.27 |
[백준] 1138 한 줄로 서기 : 실버 2 (java) - 빽트래킹 (1) | 2024.11.26 |